Склад адресного хранения. Тестовое задание (пример решения)

Публикация № 1676780 16.06.22

Управление - Подготовка к аттестации

адресная система хранения. тестовое задание программиста

Тестовое задание по адресному складу. Пример реализации в виде конфигурации, посвященной управлению движением на этом складе. Реализовано через объект Ячейка = Паллета. Справочника Склады нет... соответственно, в отличие от стандартного варианта в УПП, у ячейки нет Владельца, в документах нет реквизита Склад - чисто модель склада самого по себе.

Тестовое задание

Дано:

Есть склад, на котором реализована адресная система хранения.

Каждое место хранения маркируется 3-х значным индексом вида:

<SS><NN><LL>

Где, SS номер ряда стеллажей, NN – номер стойки в ряду стеллажей, LL уровень стеллажа.

На складе ведется только количественный учет, без суммового.

Хранение товаров на складе определяется следующими правилами:

  • На каждом месте хранения одновременно может находиться только товар одного вида (один SKU).
  • Каждому товару присуще свойство – коэффициент паллетирования, указывающий сколько единиц хранения товара составляет паллету.
  • На одном месте хранения может храниться не более одной полной паллеты.

 

Задание:

Реализовать процессы склада, отвечающие следующим критериям:

Процесс

Критерий

Прием товара

Занять как можно меньше свободных мест хранения, соответственно оставить как можно больше свободных мест хранения

Инвентаризация

Частичная инвентаризация по товарным позициям или по местам хранения (ряд, стойка, уровень).

 

Создать следующие отчеты:

Отчет

Описание

Остатки товара

Остатки товара на складе по местам хранения

Загруженность склада

Временная диаграмма загруженности склада за выбранный период

 

Реализация похожа на ту, что в этой публикации //cat.1module.ru/1c/articles/556329/

Реализована конфигурация управления адресным складом., подход немного иной - через объект СкладскаяЯчейка, которая по сути есть паллета

1. Реализован алгоритм помещения на склад (размещения на паллете (складская ячейка)) произвольного количества некоего произвольного товара (генерируется автоматически случайным числом).

&НаСервере
Функция РазместитьТоварыПоЯчейкамСклада()
	тз = Новый ТаблицаЗначений;            	
	тз.Колонки.Добавить("Номенклатура", Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));	
	тз.Колонки.Добавить("Ячейка", Новый ОписаниеТипов("СправочникСсылка.СкладскиеЯчейки"));	
	тз.Колонки.Добавить("КоличествоПриход", Новый ОписаниеТипов("Число",,, Новый КвалификаторыЧисла(5,0,ДопустимыйЗнак.Неотрицательный)));
	тз.Колонки.Добавить("Прим", Новый ОписаниеТипов("Строка"));

	тзТов = ЭтотОбъект.Товары.Выгрузить();		
	тзТов.Свернуть("Номенклатура","Количество");                                                                                           
	// добавл. вспомогательную колонку для отслеживания распределения,  пока не 0.
	тзТов.Колонки.Добавить("КоличОстаток", Новый ОписаниеТипов("Число",,, Новый КвалификаторыЧисла(5,0,ДопустимыйЗнак.Неотрицательный)));
	// список не задействованных или уже освободившихся ячеек	
	// вариант, когда ячейки создаются по мере их потребности., иначе - создасть полный набор заранее...
	мПустЯч = ОбщНазнСерв.ПолучитьПустыеЯчейки(ЭтотОбъект.Дата); 
	тзЯчеекЕстьМесто = ОбщНазнСерв.ПолучитьЯчейкиТовараНедозаполненные(ЭтотОбъект.Дата, тзТов.ВыгрузитьКолонку("Номенклатура"));
	
	для каждого стрИст из тзТов цикл
		стрИст.КоличОстаток = стрИст.Количество;                                         
		если стрИст.Номенклатура.КоэфПалетирования = 0  Тогда
			ВызватьИсключение "КоэфПалетирования = 0 в товаре " + стрИст.Номенклатура.Наименование;
		Конецесли;	
			
		для каждого стрТ1 из тзЯчеекЕстьМесто.Скопировать(Новый Структура("Номенклатура", стрИст.Номенклатура)) цикл
			новСтр = тз.Добавить();      
			новСтр.Ячейка = стрТ1.Ячейка;	
			новСтр.Номенклатура = стрИст.Номенклатура;        
			
			КоличествоМест = стрИст.Номенклатура.КоэфПалетирования - стрТ1.ВНаличииОстаток;
			если КоличествоМест <= стрИст.КоличОстаток Тогда                               
				новСтр.КоличествоПриход = КоличествоМест;	
			иначе
				новСтр.КоличествоПриход = стрИст.КоличОстаток;
			Конецесли;
			
			новСтр.Прим = "add";
			стрИст.КоличОстаток = стрИст.КоличОстаток - новСтр.КоличествоПриход;					
			если стрИст.КоличОстаток <= 0 Тогда   // < 0 на случай ошибок  
				прервать;
			КонецЕсли;				
		КонецЦикла;	 
		
		если стрИст.КоличОстаток > 0 Тогда  // остальное кол-во этого Товара нужно разместить в других ячейках (кратно коэф.парлет)		
			для счПя = -(мПустЯч.Количество()-1) по 0 цикл 
				новСтр = тз.Добавить();      
				новСтр.Ячейка = мПустЯч[-счПя];	
				новСтр.Номенклатура = стрИст.Номенклатура;
				если стрИст.Номенклатура.КоэфПалетирования <= стрИст.КоличОстаток Тогда
					новСтр.КоличествоПриход = стрИст.Номенклатура.КоэфПалетирования;
				иначе	
					новСтр.КоличествоПриход = стрИст.КоличОстаток;
				КонецЕсли;	
				мПустЯч.Удалить(-счПя);
				
				новСтр.Прим = "неисп";
				стрИст.КоличОстаток = стрИст.КоличОстаток - новСтр.КоличествоПриход;					
				если стрИст.КоличОстаток <= 0 Тогда   // < 0 на случай ошибок  
					прервать;
				КонецЕсли;	
			КонецЦикла
		Конецесли;    

		если стрИст.КоличОстаток > 0 Тогда  // остальное кол-во этого Товара нужно разместить уже только в новых ячейках (кратно коэф.парлет)					
			// упрощ. вариант, однако в некоторых случая при таком подходе будет создаваться +1 лишняя палета без движений по ней...
			//мНовЯч = СоздатьНовуюЯчейкуСклада(1+(стрИст.КоличОстаток/стрИст.Номенклатура.КоэфПалетирования));  
			//создаем по одной:
			пока (стрИст.КоличОстаток > 0) цикл							
				новСтр = тз.Добавить();      
				новСтр.Ячейка = ОбщНазнСерв.СоздатьНовуюЯчейкуСклада();	
				новСтр.Номенклатура = стрИст.Номенклатура;
				если стрИст.Номенклатура.КоэфПалетирования <= стрИст.КоличОстаток Тогда
					новСтр.КоличествоПриход = стрИст.Номенклатура.КоэфПалетирования;
				иначе	
					новСтр.КоличествоПриход = стрИст.КоличОстаток;
				КонецЕсли;	          
				
				новСтр.Прим = "+нов";
				
				стрИст.КоличОстаток = стрИст.КоличОстаток - новСтр.КоличествоПриход;					
				если стрИст.КоличОстаток <= 0 Тогда   // < 0 на случай ошибок  
					прервать;
				КонецЕсли;					
			КонецЦикла	
		Конецесли			
				
	КонецЦикла;
	
	возврат тз;
КонецФункции

2. Регистр сведений АдресацияСкладскихЯчеек используется для обеспечения корректности (уникальности) адресации, а так же для блокировки ячеек от их одновременного изменения в соседнем процессе. Проверяющие посчитали это лишним., вопрос спорный., конечное решение за Вами.

по поводу реквизита блокировки - проблема в том, что расчет количеств которые записаны за ячейкой ведется по текущим данным регистра накопления, и есть вероятность, что соседний документ еще не успеет прочитать изменения регистра, и назначит на эти ячейки свое количество. Реквизит добавлен, но пока не использован., тк в задании не оговаривалось.

3. В целях тестирования добавлен документ списания, который позволяет списать единичные позиции с паллет, чтобы образовались "дырки", которые потом должен заполнить алгоритм поступления на склад. Однако, это явилось поводом снижения баллов (лишние метаданные)

Код его движений:

&НаСервере
Функция ПолучитьТоварыПоЯчейкамСклада()
	тз = Новый ТаблицаЗначений;            	
	тз.Колонки.Добавить("Номенклатура", Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));	
	тз.Колонки.Добавить("Ячейка", Новый ОписаниеТипов("СправочникСсылка.СкладскиеЯчейки"));	
	тз.Колонки.Добавить("КоличествоРасход", Новый ОписаниеТипов("Число",,, Новый КвалификаторыЧисла(5,0,ДопустимыйЗнак.Неотрицательный)));

	тзТов = ЭтотОбъект.Товары.Выгрузить();	
	
	тзТов.Свернуть("Номенклатура","Количество");                                                                                           
	// добавл. вспомогательную колонку для отслеживания распределения,  пока не 0.
	тзТов.Колонки.Добавить("КоличОстаток", Новый ОписаниеТипов("Число",,, Новый КвалификаторыЧисла(5,0,ДопустимыйЗнак.Неотрицательный)));

	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТоварыВЯчейкахОстатки.Номенклатура КАК Номенклатура,
		|	ТоварыВЯчейкахОстатки.Ячейка КАК Ячейка,
		|	ТоварыВЯчейкахОстатки.ВНаличииОстаток КАК ВНаличииОстаток,
		|	0 КАК Расход
		|ИЗ
		|	РегистрНакопления.ТоварыВЯчейках.Остатки(&НаДату, Номенклатура В (&ТребНоменкл)) КАК ТоварыВЯчейкахОстатки
		|
		|УПОРЯДОЧИТЬ ПО
		|	ТоварыВЯчейкахОстатки.Ячейка.Код УБЫВ";
	
	Запрос.УстановитьПараметр("НаДату", Дата);  
	Запрос.УстановитьПараметр("ТребНоменкл", тзТов.ВыгрузитьКолонку("Номенклатура")); 
	
	тзОстаткиПоЯчейкам = Запрос.Выполнить().Выгрузить();			
	
	для каждого стрПотреб из тзТов цикл
		стрПотреб.КоличОстаток = стрПотреб.Количество;                                         
		мСтрНом = тзОстаткиПоЯчейкам.НайтиСтроки(Новый Структура("Номенклатура", стрПотреб.Номенклатура) );
		
		для каждого стрТ1 из мСтрНом цикл   
			если стрТ1.ВНаличииОстаток >= стрПотреб.КоличОстаток Тогда
				стрТ1.Расход = стрПотреб.КоличОстаток;
			иначе	                                  
				стрТ1.Расход = стрТ1.ВНаличииОстаток;
			КонецЕсли;
			стрПотреб.КоличОстаток = стрПотреб.КоличОстаток - стрТ1.Расход;
			
			если стрПотреб.КоличОстаток <= 0 Тогда   // < 0 на случай ошибок  
				прервать;
			КонецЕсли;				
		КонецЦикла;	
		если стрПотреб.КоличОстаток > 0 Тогда   // не хватает  
			ВызватьИсключение "Товара " + стрПотреб.Номенклатура.Наименование + " не хватило: " + Строка(стрПотреб.КоличОстаток);;
		КонецЕсли;						
	КонецЦикла;	     
	
	для каждого стр из тзОстаткиПоЯчейкам.НайтиСтроки(Новый Структура("Расход", 0)) цикл
		тзОстаткиПоЯчейкам.Удалить(стр);
	КонецЦикла;	 
			  
	возврат тзОстаткиПоЯчейкам;
КонецФункции

4. Инвентаризация

сделана лишь в части заполнения тч товары расчетными количеством по двум вариантам - по адресам или по товару свернуто.

в задании не описаны требования, соответственно, ввод факта, расчет расхождений и проведение НЕ ДЕЛАЛ. 

5. Диаграмма сделана дважды. По тем датам, по которым были движения (что логично, тк в интервалах изменений нет), и по всем датам периода (что привело к расширению диаграммы столбиками одинаковой длины.

Реализована на СКД через соединение двух источников данных (запросов). один из который дает периоды а второй значений в эти периоды. Так проще, чем делать запрос с последовательным получением остатка на начало, соединять с оборотами за период.

Однако, есть мнение, что такой подход не оптимален.

Платформа 8.3.14.

Скачать файлы

Наименование Файл Версия Размер
Склад Адресного хранения. тестовое задание: - конфигурация

.cf 123,69Kb
0
.cf 123,69Kb Скачать
Склад Адресного хранения. тестовое задание, вариант решения.

.dt 100,77Kb
0
.dt 100,77Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Мобильный ТСД, Инвентаризация, Маркировка, Штрихкод Промо

Розничная торговля Терминал сбора данных Склад и ТМЦ Оптовая торговля Загрузка и выгрузка в Excel Сканер штрих-кода v8::ОУ v8::Mobile 8.3.14 Розница УНФ ERP2 БП3.0 УТ11 КА2 Абонемент ($m)

Мобильный терминал сбора данных для смартфонов и ТСД. Синхронизация между Вашей 1С и мобильным приложением осуществляется через HTTP-сервис (http или https) или промежуточный файл. Приложение для тех, кому важна безопасность данных, так как промежуточные сервисы для обмена не используются. Приложение поддерживание шифрование данных при обмене.

1 стартмани

27.12.2020    28032    471    1cspec    196    

Множественные дополнительные реквизиты в УТ 11.4

Оптовая торговля Розничная торговля Склад и ТМЦ Адаптация типовых решений 8.3.14 УТ11 Россия УУ Абонемент ($m)

Реализация множественных дополнительных реквизитов в расширении конфигурации УТ 11.4.

5 стартмани

28.02.2022    1807    3    DrWeb3    4    

Оцифровка и визуализация склада

Склад и ТМЦ v8 v8::УФ 1cv8.cf Абонемент ($m)

Программная прорисовка склада, магазина, уличных мест хранения - оцифровка и визуализация адресного хранения.

2 стартмани

17.11.2021    7621    20    Rustig    59    

Обработка создания сборок/разборок по комплектациям и заказу покупателя с учетом остатков. УТ 11.4.13

Склад и ТМЦ v8 8.3.14 УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Обработка создает сборки/разборки с учетом того, чтобы на остатках было ровно столько комплектов, сколько нужно для продажи текущего заказа. Добавляется во внешние обработки.

10 стартмани

30.08.2021    2590    2    77ibragimoff    0    

Управление складом (альтернатива ордерной схеме) [Расширение] Промо

Склад и ТМЦ v8 v8::ОУ УТ11 УУ Абонемент ($m)

Альтернативный ордерной схеме процесс отгрузки и приемки товаров со склада. Для тех, кто не хочет использовать ордерную схему, но желает автоматизировать склад.

2 стартмани

25.02.2020    14865    10    UstinovVA    17    

Выборочный контроль остатков Розница

Розничная торговля Склад и ТМЦ 8.3.14 Розница Розничная и сетевая торговля (FMCG) Абонемент ($m)

Позволяет при установке контроля отрицательных остатков продавать указанную номенклатуру "В минус". Важно при продаже весового товара или при отложенной приемке скоропортящихся продуктов.

5 стартмани

17.06.2021    3687    5    asdfgcom    18    

Выгрузка остатков на сервис INSCOM

Склад и ТМЦ Загрузка и выгрузка в Excel WEB v8 8.3.14 УТ11 Россия Абонемент ($m)

Обработка для выгрузки отчета остатков в формате CSV для сервиса "INSCOM". Работает на УТ 11.4 Дописок базы не требует, в рамках штатной конфигурации.

2 стартмани

16.06.2021    2800    0    hottion    0    

Корректировка отрицательных остатков партий для БП 3.0

Склад и ТМЦ 8.3.14 БП3.0 Россия БУ Абонемент ($m)

Обработка корректировки возникших отрицательных остатков по партиям для БП 3.0 через документ Операция.

2 стартмани

10.06.2021    2823    31    LordSolar    1    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Склад и ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    32019    81    hrip    10    

Решение тестовых заданий на собеседовании

Подготовка к аттестации v8 8.3.14 1cv8.cf Россия Абонемент ($m)

Проходил собеседование. Было предложено решить тестовые задания. Может, кому будет интересно.

1 стартмани

02.04.2021    5270    9    gonzaomsk    1    

Android смартфон в качестве сканера штрихкодов для 1С. Маркировка, инвентаризация, 2D, DataMatrix

Сканер штрих-кода Розничная торговля Склад и ТМЦ 8.3.14 1cv8.cf УУ Абонемент ($m)

Мобильное приложение для использования Android смартфона в качестве сканера штрихкодов для 1С. Маркировка, проведение инвентаризации, честный знак, ЕГАИС, ВетИС, МДЛП, все типы штрихкодов. Аналог сканера штрихкодов. Инструмент для работы со штрихкодами и маркированным товаром.

3 стартмани

29.03.2021    8195    24    RPGrigorev    29    

Простая конфигурация по учету перемещения техники

Склад и ТМЦ 8.3.14 УУ Абонемент ($m)

Нужно было сделать журнал по перемещению техники, в разрезе по сотрудникам и местам расположения, причем у сотрудника могла находиться техника в нескольких местах расположения одновременно. В открытом доступе не нашёл ничего подобного и бесплатного. Учитывается перемещение учетной техники по организации, с контролем остатков. Используются регистры накопления и сведений.

1 стартмани

19.03.2021    3023    3    user1342811    0    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Склад и ТМЦ Инструментарий разработчика v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    68107    277    informa1555    239    

Детальные описания решений всех билетов экзамена 1C:Специалист-консультант УТ. Пример пояснительной записки. Список отчетов для предоставления экзаменаторам. Актуально на март 2022 г.

Подготовка к аттестации v8 УТ11 УУ Абонемент ($m)

Представляю вашему вниманию детальные описаний решений экзамена «1С:Специалист-консультант по внедрению прикладного решения 1С:Управление торговлей 8» с образцом пояснительной записки и описанием настройки отчетов для проверяющих.

6 стартмани

16.03.2021    11327    205    PoZiTiFFF    35    

Документооборот, задачи, простой учет ТМЦ

Документооборот и делопроизводство Склад и ТМЦ Анализ и проектирование ИТ-систем v8 8.3.14 Россия УУ Абонемент ($m)

Учет входящей и исходящей корреспонденции, ведение задач, учет ТМЦ.

1 стартмани

18.02.2021    3967    16    pawellkrv    11    

Отбор по дате распоряжений в АРМ "Приемка товаров на склад"

Рабочее место Склад и ТМЦ 8.3.14 ERP2 УТ11 КА2 БУ УУ Абонемент ($m)

Расширение добавляет возможность установки периода для отбора по дате распоряжений в типовых конфигурациях УТ 11, КА 2 и ERP 2 на форме обработки "Приемка товаров на склад" (АРМ "Приемка").

1 стартмани

18.02.2021    2720    3    Key2Key    0    

Система тестирования. Тренажер для тестирования. Подготовка к профессионалу по 1С (1С:Профессионал), школьные тесты, вопросы ПДД, корпоративные проверки и многое другое Промо

Подготовка к аттестации v8::УФ Россия Абонемент ($m)

Конфигурация (программа) служит для подготовки к тестированию, а также возможности организации тестовой проверки. Функционал получился универсальный, подойдёт для подготовке к любой сдаче профессионала по платформе, ERP, бухгалтерии и др. Так же можно вносить другие тесты - вопросы по правилам дорожного движения или школьные тесты. Если у вас в компании есть внутренние обучения, с помощью данной программы вы можете закреплять пройденный курс.

1 стартмани

31.10.2017    40547    112    rpgshnik    61    

Массовая генерация и печать кодов SSCC для агрегации товаров в монотоварные упаковки маркированных товаров

Розничная торговля Склад и ТМЦ 8.3.14 ERP2 УУ Абонемент ($m)

Встраиваемая стандартным методами дополнительная обработка позволяет массово генерировать коды SSCC для маркировки монотоварных упаковок маркированного товара.

2 стартмани

22.01.2021    3749    9    Akvals    2    

Небольшой склад. Программа учета складских остатков

Оптовая торговля Склад и ТМЦ v8 v8::ОУ 8.3.14 Россия УУ Абонемент ($m)

Конфигурация складского учета небольшого склада (на базе 1С 8.3). Товары и услуги, с ценами и штрих кодами (приход/расход, инвентаризация -> списание/оприходование перемещение между магазинами, отчет по товарам и продажам).

5 стартмани

12.01.2021    4018    9    rider_vk    7    

Решение сборника задач для подготовки к экзамену 1С Специалист-консультант ЗУП

Подготовка к аттестации 8.3.14 ЗУП3.x Россия БУ УУ Абонемент ($m)

Решение всех задач сборника для подготовки к экзамену 1С Специалист-консультант ЗУП.

2 стартмани

20.11.2020    5176    53    ToroNatali    7    

Экзамен 1С:Специалист по платформе 8.3. Полностью решенные ВСЕ билеты экзамена (актуальны на март 2022 г.). Промо

Подготовка к аттестации Абонемент ($m)

В публикации представлены полностью решенные билеты экзамена (ВСЕ 16 БИЛЕТОВ ЭКЗАМЕНА + Новые дополнительные задачи) с учетом последних нововведений в заданиях экзамена.

1 стартмани

18.07.2016    171261    6260    PoZiTiFFF    383    

Подготовка к экзамену 1С: Специалист ЗУП. Билет № 1

Подготовка к аттестации 8.3.14 ЗУП3.x Россия БУ Абонемент ($m)

Решение билета №1 - подготовка к экзамену 1С Специалист ЗУП.

2 стартмани

20.11.2020    4001    8    ToroNatali    2    

ВетИС - Инвентаризация остатков в 1С на предприятии и связанных складах

Оптовая торговля Склад и ТМЦ 8.3.14 УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Отличный помощник в выравнивании остатков между ВетИС и остатками 1С. Используется трехступенчатое сравнение из регистра сопоставление продукции ВетИС, что позволяет не смешивать ситуации, где есть точная связь между серией и записью складского журнала и ситуацией, где есть только сопоставление продукции ВетИС с номенклатурой 1С.

2 стартмани

19.11.2020    3840    7    plebedinskiy    0    

Конфигурация: Инвентаризация оргтехники 2.0

Склад и ТМЦ v8::УФ УУ Абонемент ($m)

Автоматизированная система инвентаризации оргтехники. Учет компьютеров и периферии. Учет программного обеспечения. База знаний и заявки АСУ. Складской учет

3 стартмани

02.06.2020    9248    62    WeterSoft    57    

Давно обещанная автовесовая 8.Х Промо

Склад и ТМЦ Производство готовой продукции (работ, услуг) v8 Россия УУ Абонемент ($m)

Финальная версия автовесовой без оператора.

10 стартмани

02.01.2018    29205    7    Арчибальд    1    

[Специалист-консультант] ERP (Производство и ремонты, Управленческий учет, Бюджетирование) + УТ. Решения и шпаргалки к четырем экзаменам

Подготовка к аттестации v8 ERP2 УТ11 УУ Абонемент ($m)

Решения билетов четырех экзаменов "1С:Специалист-консультант": 1) ERP Управленческий учет 2) ERP Производство 3) ERP Бюджетирование 4) Управление торговлей

3 стартмани

24.03.2020    26475    368    leobrn    92    

Готовые решения для инвентаризации товаров и основных средств на мобильных устройствах для КА, УТ, ERP и БП 3.0 на базе Simple UI

Оптовая торговля Розничная торговля Учет ОС и НМА Мобильная разработка Склад и ТМЦ v8 ERP2 БП3.0 УТ11 КА2 БУ УУ Абонемент ($m)

В расширениях для Бухгалтерия 3.0 и КА2.4/УТ11.4/ERP2.4 представлены готовые рабочие места для онлайн и оффлайн инвентаризации товаров (для БП 3.0 также инвентаризации основных средств) на базе бесплатного конструктора мобильного фронта Simple UI. При этом используется расширенная работа с идентификацией товаров и ОС с помощью различных подходов – сканирование штрих кода, распознавание артикулов и инвентарных номеров и различные поиски. Также используются различные возможности платформы Simple UI. Данная разработка может быть полезна как конечным пользователям, так и разработчикам в качестве заготовки, так как на базе этих блоков можно сделать ввод любого документа конфигурации , связанного с товаром или с ОС. Тестировалось на 1С 8.3.13.1865, КА 2.4.8.63 и БП 3.0.74.69

5 стартмани

28.02.2020    19614    84    informa1555    76    

Сдаём экзамен на специалиста

Подготовка к аттестации v8 Россия Абонемент ($m)

Очередная публикация на популярную тему о сдаче экзамена "Специалист по платформе".

1 стартмани

11.12.2019    13860    14    gero    15    

Остатки на каждый день в запросе Промо

Склад и ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    87598    22    arakelyan    27    

Решенные билеты для экзамена Специалист по платформе. 2019

Подготовка к аттестации v8 Абонемент ($m)

Архив с 16 решенными билетами для экзамена по платформе 2019. Выполнено на платформе 8.3.11. Решения не содержат текстов задач.

2 стартмани

25.09.2019    23525    209    kassbar    8    

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. UPD Устарело (см. Simple UI)

Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Склад и ТМЦ v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    23556    46    informa1555    41    

Специалист по платформе (алгоритм подготовки + решенные билеты)

Подготовка к аттестации v8 1cv8.cf Абонемент ($m)

Алгоритм подготовки к специалисту по платформе.

1 стартмани

17.05.2019    25538    81    Смешной 1С    21    

Решение билетов к экзамену "1С: Специалист по конфигурированию УТ 11" Промо

Подготовка к аттестации v8 УТ11 Россия Абонемент ($m)

Во вложении 2 архива (по 10-ти билетам): 1. Пояснительная записка (что и как настраивать, какие галки ставить и т.д.). 2. Отчеты (по билетам, где нужно создать отчет) Описание самих билетов - отсутствует.

1 стартмани

08.02.2016    30713    58    dimbasbear    17    

HTTP-сервис + интерфейс jquery.mobile + QR-код. Остатки в магазине с устройства под Android, Apple, Windows без установки 1С

Оптовая торговля Склад и ТМЦ v8 УУ Абонемент ($m)

Была поставлена задача: Предоставить продавцам магазина быстрый доступ к остаткам размеров товара на складе магазина не отходя от покупателя.

1 стартмани

16.01.2019    21306    15    John_d    9    

Решенные задания для сертификационного экзамена 1С: Специалист по Платформе 8.3 + Шпаргалки

Подготовка к аттестации v8 Россия Абонемент ($m)

Мои решения актуальных билетов для подготовки к экзамену 1С:Специалист по платформе. Первоначальная актуальность Ноябрь 2018 г. Кроме билетов прилагаю Удобочитаемые "Шпаргалки", по которым удобно самостоятельно готовиться - решать задачи.

1 стартмани

03.12.2018    39237    165    antonio_i    75    

Подключаем ТСД на android к УТ 10 по rdp

Терминал сбора данных Склад и ТМЦ v8 УТ10 Россия УУ Абонемент ($m)

Обработка для УТ 10.3 с удобным интерфейсом на ТСД honeywell eda60k. Запуск по rdp. Решаемые задачи - Информация о товаре, инвентаризация, перемещение, поступление товара.

1 стартмани

27.11.2018    31496    116    kida1    60    

Полное решение билетов сертификации 1С: Специалист УТ 11 Промо

Подготовка к аттестации v8 УТ10 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Решение 10 основных билетов на экзамене 1С: Специалист по УТ 11. Все билеты попадались группе пользователей, из которой сдали все.

1 стартмани

18.08.2016    32677    133    maksimov-y-v    6    

Решения билетов Специалист по платформе 8.3 (Актуально на начало 2019)

Подготовка к аттестации v8 1cv8.cf Россия Абонемент ($m)

Решенные билеты к экзамену специалист по платформе 8.3.

1 стартмани

09.07.2018    21907    140    user731414    17    

Решение задач и материалы для подготовки в одном архиве для "1С:Специалист по конфигурированию и внедрению торговых решений" / "Специалист УТ 11"

Подготовка к аттестации v8 v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Решения всех задач из сборника в одном архиве. Собрал всё , что поможет Вам подготовиться и сдать экзамен 1С:Специалист УТ 11. Комбинации билетов, рекомендации по сдаче присутствуют.

1 стартмани

06.04.2018    29245    257    leobrn    41    

Андроид-решение для создания заказов в 1С

Рабочее место Оптовая торговля Склад и ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Разработка создает заказы в 1С на Андроид-телефонах через RDP-клиент. Описана технология подобных разработок.

2 стартмани

23.03.2018    35401    28    Rustig    116    

Складские операции на ТСД Промо

Терминал сбора данных Склад и ТМЦ v8 УУ Абонемент ($m)

Складская мобильная программа для терминалов сбора данных.

1 стартмани

15.11.2015    33028    4    JetBrain    8    

Конфигурация-основа для мобильного приложения - сканер штрихкода (фото сканер и ТСД) + фото

Склад и ТМЦ Мобильная разработка Сканер штрих-кода Терминал сбора данных v8::Mobile 1cv8.cf УУ Абонемент ($m)

Конфигурация-основа для мобильной платформы. Работа с фотосканером (через приложение Barcode Scanner) и сервис для перехвата Broadcast со сканера штрих-кодов ТСД Теперь любой смартфон превратить в почти полноценный ТСД в вашем приложении. + По публикации https://infostart.ru/public/587908/: Service перехвата сообщений Broadcast со сканера штрих-кодов в мобильную платформу 1С (эмуляция внешнего события). Позволяет получать и обрабатывать штрих-коды не в разрыв клавиатуры (определенное активное окно), а "под капотом". Поддержка запуска/остановки из программного кода 1С.

5 стартмани

23.11.2017    45930    239    Vladimir45    170    

Мобильное приложение для склада с функцией голосового ввода

Мобильная разработка Склад и ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Несложное приложение под Андроид предназначенное для выполнения операций по наборке и приемке товаров на складе, а также выполнения других складских операций. Мобильная часть решения написана под терминалы сбора данных на Android. Транспорт данных - POST - запрос на HTTP сервис. Серверная часть - сервис на базе 1С сервера.

2 стартмани

08.08.2017    22273    18    Prometeus2011    21    

Загрузка всех онлайн-чеков с сервиса проверки чеков ФНС (налоговой) – обработка для получения данных о покупках по чекам онлайн-касс с загрузкой в Авансовый отчет

Внешние источники данных Документооборот и делопроизводство Кассовые операции Розничная торговля Склад и ТМЦ v8 УНФ БП3.0 Россия Абонемент ($m)

В продолжение статьи «Свой кусочек информационного пирога по 54-ФЗ – обработка для получения данных о своих покупках по чекам ОФД» (на примере сети магазинов «Лента») (http://infostart.ru/public/647711/). Однако, в предыдущей публикации был показан пример получения данных с сервиса ОФД Такском по одному магазину, в новой публикации – показан пример загрузки всех чеков по всем ОФД непосредственно с сервиса проверки чеков ФНС. Опубликованы обработки, позволяющие работать по двум схемам: вносить данные по каждому чеку, получая данные с ФНС, или загружать чеки в мобильное приложение ФНС, выбирая в последующем для загрузки нужные чеки из списка. К публикации приложен файл расширения для печати Заявления на возмещения затрат подотчетного лица.

10 стартмани

26.07.2017    41149    174    delta    118    

Штрихкодовая линейка для автоматизации измерения габаритов Промо

Рабочее место Склад и ТМЦ v8 КА1 УТ10 УПП1 Абонемент ($m)

Предлагаемые на рынке лазерные системы автоматизированного измерения габаритов хотя и имеют высокую производительность, но цены на них начинаются от 1 млн. руб. И надо еще установить, подключить, интегрировать в учетную систему. Для обычных складов это, конечно, очень дорого. Поэтому задачи по измерению грузов они решают с помощью рулетки и листочка с карандашом. Значительные потеря и искажение информации здесь неизбежны. Мы предлагаем эффективное решение стоимостью менее 10 тыс. руб. Штрихкодовая линейка - простой и надежный инструмент для автоматизированного измерения и ввода в информационную систему линейных габаритов товаров.

1 стартмани

24.12.2013    31039    24    cortesru    19    

Пополнение товара на складе по теории ограничения систем

Оптовая торговля Склад и ТМЦ Математика и алгоритмы v8 КА1 УПП1 УУ Абонемент ($m)

В статье рассматривается алгоритм пополнения склада по теории ограничений систем. Сами подходы описаны в книге Элия М. Голдратта «Я так и знал! Теория ограничений для розничной торговли».

1 стартмани

26.01.2017    20113    16    vva    6    

ВСЕ решенные задачи к экзамену 1С Специалист по Платформе 8.2, ред. 3 Промо

Подготовка к аттестации v8 1cv8.cf Россия Абонемент ($m)

ВСЕ решенные задачи к экзамену 1С Специалист по Платформе 8.2, ред. 3

1 стартмани

16.12.2012    51889    996    nord97    1