Печатаем ОнЛайн чеки из 1С в Windows и Linux, на ПК и RaspberryPI. Атол, Штрих-М. Из файлов (csv), WebAPI, FTP, Ajax.

Публикация № 872959

Администрирование - Администрирование данных 1С

В последнее время появилось множество программ, которые позволяют организовать печать кассовых чеков на ОнЛайн кассах путем выгрузки файла-задания. Но вот беда: все они заточены на работу в ОС Windows... Мы расширяем эти границы и предлагаем печать чеков на любом ФР Атол или Штрих-М в ОС Windows, Linux (Debian, Ubuntu, Mint, RedHat, CentOS), а так же на микро-ПК RaspberryPI!

Программа Кассовый сервер позволяет решить массу задач, связанных с печатью чеков на ОнЛайн кассах:

  • печать на одной кассе с нескольких рабочих мест кассиров
  • работа с несколькими ККМ, подключенными к одному ПК
  • ускорение печати чека из терминальной RDP-сессии
  • организация ультра-бюджетного кассового узла на базе RasbperryPI (не нужны лицензии Windows, Office, антивирусы и лицензии на терминальные подключения (FreeNX)). 

Программа полностью соответствует требованиям ФФД 1.0 и 1.05.
Полностью кроссплатформенная. Имеются готовые сборки для разных ОС.
Универсальное и очень простое API, которое не зависит от ОС или используемой ККМ.
 

Для облегчения изучения API имеется встроенный конструктор запросов. Вводите параметры и выбираете команду - в нижней части экрана пишется строка-команда, которая тут же исполняется на ККМ.

Программа проста в настройке оборудования. Для настройки связи с ККМ имеется конфигуратор


 

Кассовый сервер можно использовать как самостоятельное рабочее место кассира:  имеется встроенное рабочее место кассира, позволяющее пробить любой чек.

 

Касса всегда под контролем. А все операции протоколируются:

 

Так же для действующих и потенциальных клиентов действует техподдержка. Помогаем настроить ККМ, программу. Консультируем по вопросам интеграции...

Пример генерации самого простого чека 1С 7.7
 

Функция глПреобразоватьСтрокуВУТФ8(Стр) Экспорт
    Длина=СтрДлина(Стр);
    Итог="";
    Для Н=1 По Длина Цикл
        Знак=Сред(Стр,Н,1);
        Код=КодСимв(Знак);
        Если Код<128 Тогда
            Итог=Итог+Знак;
        Иначе
            Если (Код>=КодСимв("А"))И(Код<=КодСимв("п")) Тогда
                Итог=Итог+Симв(208)+Симв(144+Код-КодСимв("А"));
            ИначеЕсли (Код>=КодСимв("р"))И(Код<=КодСимв("я")) Тогда
                Итог=Итог+Симв(209)+Симв(128+Код-КодСимв("р"));
            ИначеЕсли (Знак="ё") Тогда
                Итог=Итог+Симв(209)+Симв(145);
            ИначеЕсли (Знак="Ё") Тогда
                Итог=Итог+Симв(208)+Симв(129);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    Возврат Итог;
КонецФункции

Процедура ПечатьККМ()
	Если ЧерезИП=1 Тогда
		АвтоВремяТекущее();
		Записать();
        Ф = СоздатьОбъект("Текст");  
		Если СокрЛП(Автор.login)="GlManager" Тогда
			Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;0;ГЛАВНЫЙ_КАССИР;"));
		Иначе
			Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;0;"+Автор+";"));
		КонецЕсли;
		ИтогСумма=0;
		ВыбратьСтроки();
		Пока ПолучитьСтроку() = 1 Цикл 
			Если Товар.ВидТовара=Перечисление.ВидыТоваров.Услуга Тогда
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+Товар.Наименование+";"+(Цена*100)+";"+(Количество*1000)+";6;1;0"));
			Иначе
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+Товар.Наименование+";"+(Цена*100)+";"+(Количество*1000)+";6;0;0"));
			КонецЕсли;
			ИтогСумма	= ИтогСумма + Сумма;
        КонецЦикла;
		Если СокрЛП(Контрагент.Наименование)="Клиент пластик" Тогда
			Ф.ДобавитьСтроку("tmde;0;"+(ИтогСумма*100)+";0;0;6;0;0;0");
		Иначе
			Ф.ДобавитьСтроку("tmde;"+(ИтогСумма*100)+";0;0;0;6;0;0;0");
		КонецЕсли;
		Ф.Записать("D:\KKM\check"+НомерДок+".txt");
	КонецЕсли;
КонецПроцедуры 



Пример генерации чека, с указанием ФИО кассира, разбивкой по СНО (УСНО доходы  и ЕНВД), отправкой электрочека на почту или телефон.  1С 7.7

        Ф = СоздатьОбъект("Текст");  
		ИтогСумма=0;
		ДопСумма=0;
		Флаг=0;
		ДопЧек=СоздатьОбъект("Текст");
		ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;"+?(ВидОперации = Перечисление.ВидыОперацийЧекККМ.Чек,0,1)+";"+Автор+";"));
		ВыбратьСтроки();
		Пока ПолучитьСтроку() = 1 Цикл 
			Ц=Окр(Сумма/Количество,2,1);
			//Сообщить(Сумма+","+Количество+","+Ц);
			Если Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга Тогда
				Если Флаг=0 Тогда 
					Ф.ДобавитьСтроку("set_tlv;1055;1;2;");  // УСНО Доходы
					Флаг=2;
				ИначеЕсли Флаг=8 Тогда
					Если ДопСумма=0 Тогда ДопЧек.ДобавитьСтроку("set_tlv;1055;1;2;"); КонецЕсли;  // УСНО Доходы
					ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;2;"));
					ДопСумма	= ДопСумма + (Ц*Количество);
					Продолжить;
				КонецЕсли;
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;2;"));
			Иначе
				Если Флаг=0 Тогда 
					Ф.ДобавитьСтроку("set_tlv;1055;1;8;");  // ЕНВД
					Флаг=8;
				ИначеЕсли Флаг=2 Тогда
					Если ДопСумма=0 Тогда ДопЧек.ДобавитьСтроку("set_tlv;1055;1;8;"); КонецЕсли;  // ЕНВД
					ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;1;"));
					ДопСумма	= ДопСумма + (Ц*Количество);
					Продолжить;
				КонецЕсли;
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;1;"));
			КонецЕсли;
			ИтогСумма	= ИтогСумма + (Ц*Количество);
		КонецЦикла;

		Если ПустоеЗначение(Контрагент)=0 Тогда
			Д="";
			Если Контрагент.ОтправкаЧека=Перечисление.ОтправкаЧека.ТелефоныФизЛица Тогда
				Д=СокрЛП(Контрагент.ЮрФизЛицо.Телефоны);
			ИначеЕсли Контрагент.ОтправкаЧека=Перечисление.ОтправкаЧека.ЭлПочта Тогда
			    Д=СокрЛП(Контрагент.ЭлПочта);
			КонецЕсли;
		КонецЕсли;
		Если ПустоеЗначение(Д)=0 Тогда 
			Ф.ДобавитьСтроку("set_tlv;1008;5;"+Д+";");
		КонецЕсли;
		
		Если ПлатежнаяКарта=1 Тогда
			Ф.ДобавитьСтроку("tmde;0;"+(ИтогСумма*100)+";0;0;6;0;0;0;");
		Иначе
			Ф.ДобавитьСтроку("tmde;"+(Макс(Получено,ИтогСумма)*100)+";0;0;0;6;0;0;0;");
		КонецЕсли;
		Ф.Записать("C:\RndItSoft\Checks\"+НомерДок+".txt");
		
		Если ДопСумма>0 Тогда
			Если ПустоеЗначение(Д)=0 Тогда 
				ДопЧек.ДобавитьСтроку("set_tlv;1008;5;"+Д+";");
			КонецЕсли;
			
			Если ПлатежнаяКарта=1 Тогда
				ДопЧек.ДобавитьСтроку("tmde;0;"+(ДопСумма*100)+";0;0;6;0;0;0;");
			Иначе
				ДопЧек.ДобавитьСтроку("tmde;"+(Макс(Получено-ИтогСумма,ДопСумма)*100)+";0;0;0;6;0;0;0;");
			КонецЕсли;
			ДопЧек.Записать("C:\RndItSoft\Checks\"+НомерДок+"_2.txt");
			
        КонецЕсли;

Работа с Кассовым сервером из Web-приложения.  Печать чека из PHP
 

/**
 * Class Sale
 */
class Sale{

    /**
     * Печать чека
     * @param int $id id из sale
     */
    static function CheckKKM($id=0){

        $buf="B;".(isset($_REQUEST['returnsale'])?"1":"0").";".(User::comment()?User::comment():"Колесников Д.Г.").";\n";
        $add_summ=$summ=0;
        if(!($sale=DB::Select("sale",($id>0?"id=".intval($id):"user='".$_SESSION['user']['id']."' ORDER by time DESC"))) )fb_err("Нет доступной операции для печати чека!");
        // todo нельзя пробить чек на несегодняшнюю продажу
        $id=$sale['id'];
        $add_chek='';
        $flag=0;
        // $sale['visa'] - эта часть оплачена платиком, остальное наличными
        $query=DB::sql("SELECT * FROM `".self::db_prefix."sale2` WHERE sale='".$id."'");
        while(($data = DB::fetch_assoc($query))){
            $tovar=Tovar::GetTovar($data['tovar'],1); if(!$tovar)fb_err("Нет товара № ".$data['tovar']);
            if($tovar['type']==TYPE_TOVAR){
                if($flag==0){  $buf .= "set_tlv;1055;1;8;\n";  $flag=8; } // ЕНВД
                elseif($flag!=8){
                    $add_chek.= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;0;\n";
                    $add_summ+=$data['summ'];
                    continue;
                }
                $buf .= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;0;\n";
            }else{
                if($flag==0){  $buf .= "set_tlv;1055;1;2;\n"; $flag=2; } // УСНО Доходы
                elseif($flag!=2){
                    $add_chek.= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;1;\n";
                    $add_summ+=$data['summ'];
                    continue;
                }
                $buf .= "SMDE;Загар в солярии;".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;1;\n";
            }
            $summ+=$data['summ'];
        }
        if($summ>0){
            $sale_visa=min($sale['visa'],$summ);
            $buf.="tmde;".(($summ-$sale_visa)*100).";".($sale_visa*100).";0;0;6;0;0;0;"/*.";\n"*/;
            // если сегодня это первый чек, открыть смену
            if(!DB::Select("sale","`services`&2 and time>='".date("Y-m-d")."'")){
                $buf="open_session;\n".$buf;
            }
            self::CmdKKM($buf,$id);
            DB::sql("UPDATE `" . db_prefix . "sale` SET `services`=`services`|".(isset($_REQUEST['returnsale'])?"4":"2")." WHERE id=" . $id);
            if($add_summ>0){ // второй чек по другой СНО
                $buf="B;".(isset($_REQUEST['returnsale'])?"1":"0").";".(User::comment()?User::comment():"Колесников Д.Г.").";\n".
                    "set_tlv;1055;1;".($flag==8?2:8).";\n" . $add_chek;
                $sale_visa=min($sale['visa'],$summ);
                $buf.="tmde;".(($summ-$sale_visa)*100).";".($sale_visa*100).";0;0;6;0;0;0;"/*.";\n"*/;
                self::CmdKKM($buf,$id.'_2');
            }
        }
    }


    /**
     * Отправить команду в KKM
     * @param string $format =
     *  open_session;
     *  X;
     *  Z;
     *  g; анулировать последний открытый чек
     */
    static function CmdKKM($format='x',$id='')
    {
        $format.=";\n";
        file_put_contents('C:\RndItSoft\Checks\chek'.$id.'.txt', Convert::win2utf($format));
        file_put_contents($_SERVER['DOCUMENT_ROOT'].'/log/chek.log', $format."\n\n", FILE_APPEND);
    }

}

 

Причины купить

Решение актуальных проблем с печатью чеков, в том числе из старых конфигураций и проблемных RDP-сессий.
Полное соответствие ФФД 1.0 1.05 и большей части 1.1
Возможность получить результат исполнения команды (например, фискальный признак или фискальный номер документа).
Возможность организовать работу с одной ККМ разных кассиров (даже территориально в разных офисах).
Возможность отключить печать чека (только электрочек).
 

Достоинства

Единственный кассовый сервер, работающий в разных операционных системах и предоставляющий такой широкий набор функций.

Простота интеграции и предсказуемость результата работы.

Встроенный анализатор нештатных ситуаций.

Возможность адаптации ПО под требования заказчика (отдельная опция).

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
Руководство по установке и настройке.
.pdf 1,46Mb
23.07.18
26
.pdf 1,46Mb 26 Скачать бесплатно
Руководство программиста: описание API (FileAPI, AjaxAPI, WebAPI)
.pdf 1 003,49Kb
23.07.18
14
.pdf 1 003,49Kb 14 Скачать бесплатно
26.07.2018
5.18.07.04 0 1300 руб.

Моментальная
доставка

26.07.2018
5.18.06.20 0 1300 руб.

Моментальная
доставка

26.07.2018
5.18.07.04 0 1300 руб.

Моментальная
доставка

26.07.2018
0 500 руб.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. capitan 1627 27.07.18 10:11 Сейчас в теме
Первый раз вижу чтобы руководство по настройке стоило стартмани
Видимо очень крутая обработка )
2. Техподдержка 27.07.18 15:27
(1)Здравствуйте. Конечно же бесплатно. Просто в соответствии с правилами добавления программ в ИнфоСтарт до момента подписания договора любое размещаемое вложение должно иметь минимальную цену в 1 стартмани.

Стоимость изменена на "Бесплатно".
3. obmanOZ 22 02.01.19 22:10 Сейчас в теме
Добрый день! Подскажите, организована ли поддержка НДС 20% на кассе Штрих онлайн?
Оставьте свое сообщение

См. также

SALE! 20%

Видеокурс "Администратор 1С" v: 2.2 Промо

Администрирование данных 1С Платные (руб)

Вход в профессию Администратор 1С - с зарплатой от 60 000 рублей! Вы станете настоящим техническим специалистом по IT инфраструктуре 1С Предприятия, научитесь правильно устанавливать, настраивать обслуживать 1С Предприятие и все сопутствующее программное обеспечение.

3200 руб.

03.04.2017    40342    124    22    

Ускорение работы кассы Атол через RDP и VPN. Быстрая печать чеков на кассах Атол в RDP

ККМ Кассовые операции v8 1cv8.cf Платные (руб)

Комплект программ, позволяющих значительно увеличить скорость работы ККМ Атол в RDP-сессиях. Позволяет с минимальными переделками на стороне клиента добиться нормальной работы кассы. Работа как в виде CLI-приложения, так и в виде сервиса. На стороне сервера не запускаются посторонние процессы и не вносятся никакие изменения в конфигурации.

2000 руб.

18.09.2019    6292    16    26    

Загрузка курсов валют НБРБ (обычная и управляемая форма)

Обработка справочников Банковские операции WEB Банковские операции v8 v8::УФ 1cv8.cf Беларусь БУ Платные (руб)

Загрузка курсов валют с сайта НБРБ (Национального банка Республики Беларусь) версия 2.0 на обычных и управляемых формах по API. Не требует подписки на ИТС!

2000 руб.

08.10.2018    10087    8    0    

Две или более касс РМК Розница 2.2. ИНН покупателя РМК. Промо

ККМ Кассовые операции Розничная торговля Ценообразование, анализ цен Кассовые операции Розничная торговля Ценообразование, анализ цен v8 Розница Россия Платные (руб)

Часто задаваемый вопрос, можно ли в 1С:Розница подключить несколько касс к на одно рабочее место?! Теперь можно. Обработка позволяет подключать не ограниченное количество касс на одно рабочее место, и выбирать, когда на какой кассе пробивать чек, не всегда, только когда это не обходимо. Публикация состоит из двух файлов, можно подключить расширение конфигурации для ПРОФ версии. Для базовой версии внешняя обработка РМК.

2000 руб.

07.08.2018    27772    156    115    

1С:Корпоративный инструментальный пакет 8 (1С:КИП)

Администрирование данных 1С v8 1cv8.cf Россия Платные (руб)

«1С:Корпоративный инструментальный пакет 8» (1С:КИП) предназначен для повышения производительности, масштабируемости и надежности информационных систем, работающих на платформе «1С:Предприятие 8» за счет решения широкого круга технических задач, возникающих на всех этапах жизненного цикла информационной системы.

100800 руб.

09.09.2018    5845    7    0    

Онлайн-кассы (54-ФЗ). Печать чека ККМ из Реализации товаров и услуг в УТ 10.3

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ10 Платные (руб)

Онлайн-кассы (54-ФЗ). Печать чека ККМ с номенклатурой из Реализации товаров и услуг (РТиУ). УТ 10.3. (Протестировано на платформе 8.2.19.130, релиз 10.3.47.3., а также на платформе 8.3.14 на релизе 10.3.54.3) 

1000 руб.

03.07.2018    15482    14    2    

АИС: Онлайн-кассы для 1С 7.7 (с поддержкой маркировки ЕГАИС, ТАБАКА, ОБУВИ, ЛЕКАРСТВ, МЕХА, ШИН, ОДЕЖДЫ и пр.) Промо

Фискальный регистратор Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ТиС Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Подключение фискального регистратора к 1С 7.7 в режиме онлайн-кассы (в соответствии с 54-ФЗ). Поддерживаются все изменения закона с 01.07.2019. Поддержка тегов 1227,1228,1229,1230,1231 и всех остальных. Поддержка тегов для комиссионеров и платежных агентов. Поддержка крайних версий драйверов ККТ: ДТО 10 и ДТО 8 для Атол, 4.14 для Штрих-М. Поддержка протоколов ФФД 1.0, 1.05 и 1.1, развитые настройки для применения частичных оплат и авансов в оптовой и розничной торговле. Поддержка чеков коррекции всех версий. Поддержка розничной продажи маркированной продукции (ЕГАИС, табак, обувь, лекарства, шины, одежда, белье, парфюмерия и пр.), а также передача штрихкодов Средств Индивидуальной Защиты ("коронавирусный" закон). Возможно подключение без доработки конфигураций (см. список поддержки). Возможно подключение к любому виду документов, в котором или в документе-основании которого присутствует Номенклатура. Решена проблема с выводом любых скидок в чек без ошибки округления (!!!) и без изменения алгоритмов конфигурации 1С 7.7. Вывод ФИО кассира в чек в зависимости от смены. Вывод в чек ставок НДС (при необходимости). Вывод электронного чека (на е-майл, телефон) по требованию покупателя. Поддерживаются комбинированные типы оплаты: наличными и банковской картой. Имеется режим эмуляции печати чека на ФР - для тестирования алгоритмов без использования реального ФР. Поддерживается печать произвольных нефискальных строк в чеке. Реализовано через внешние обработки обслуживания конфигураций без необходимости вносить изменения в конфигурацию 1С. Код разработки полностью открыт, подлежит любой модификации под свои потребности.

2000 руб.

28.03.2017    269552    2471    2438    

Расширение для работы КА "Титан-А","Титан-A wi-fi", "Титан-ПЛЮС" с 1С:Предприятие 8

Фискальный регистратор Кассовые операции Кассовые операции v8 1cv8.cf Беларусь Платные (руб)

Расширение предназначено для работы кассового аппарата "Титан-А" ,"Титан-A wi-fi", "Титан-ПЛЮС" и конфигураций: "Управление торговлей для Беларуси" ред. 3.4 "Розница для Беларуси", ред.2.2 "1С:Комплексная автоматизация для Беларуси 2", ред.2.4 "1С:ERP Управление предприятием 2 для Беларуси", версия 2.4

3000 руб.

22.05.2018    17958    24    57    

ККТ-ОНЛАЙН 54-ФЗ, подключение к любой конфигурации(Обновлено)

ККМ Кассовые операции Кассовые операции Россия Платные (руб)

ККТ-ОНЛАЙН 54-ФЗ, подключение к любой конфигурации. Неважно, 1С 7.7 или 1С 8.Х , можно даже из exсel документа. Возможна работа с одним фискальным регистратором одновременно несколькими пользователями, работа по сети.

1500 руб.

07.08.2017    16549    9    19    

Печать чеков в соответствии с 54-ФЗ из интернет магазина и с нескольких касс на один фискальный регистратор

Фискальный регистратор Кассовые операции Розничная торговля Учет ТМЦ Кассовые операции Розничная торговля Учет ТМЦ Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Легкая промышленность, мода и одежда Пищевая промышленность Платные (руб)

Можно ли сэкономить при внедрении касс онлайн? Можно. Воспользуйтесь маршрутизатором печати. Две полезные функции маршрутизатора: 1. Вывод чеков с разных касс на один фискальный регистратор 2. Проведение продаж из интернет магазина через ОФД в on-line режиме

15000 руб.

16.06.2017    19642    29    41    

54-ФЗ. Очередь печати для ККМ. Обработки для подключения онлайн-касс к 1С 8 (поддержка маркировки Табака, Обуви, Лекарств, Меховых изделий) + Требования к чекам с 01.07.2019 + Эмулятор Промо

ККМ Фискальный регистратор Рабочее место Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 КА1 БП2.0 УТ10 Розница УПП1 БГУ БАУ Россия Платные (руб)

Обработка осуществляет обслуживание фискальных регистраторов, поддерживаемых драйвером "АТОЛ: Драйвер ККМ v.8 и v.10" И драйвером "Штрих-М: Драйвер ККТ v.4.Х" для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Для осуществления возможности параллельной работы и пробития чеков на одной ККМ несколькими пользователями, реализован механизм "Очереди печати". Реализована поддержка Веб-сервера Атол для работы с одной ККТ с нескольких рабочих мест. Соответствует требованиям российского законодательства, а именно требованиям закона ФЗ-54 об онлайн-кассах и применении контрольно-кассовой техники. Поддерживает Форматы Фискальных Данных 1.0, 1.05 и 1.1. Включен механизм использования нескольких систем налогообложения в одном документе. Содержит механизмы легкого подключения оборудования по TCP/IP, что упрощает процедуру подключения кассы в сеансах RDP, а так же позволяет подключаться к ККМ через интернет напрямую. Поддерживает работу со ставкой НДС 20%. Поддержка маркировки. Поддержка требований к кассовым чекам с 01.07.2019. Поддерживает режим эмуляции кассовых чеков.

3500 руб.

25.05.2015    202154    1255    1909    

"2iS:Пользователи" - Центр управления доступом пользователей к базам 1С

Информационная безопасность Администрирование данных 1С v8 Платные (руб)

Конфигурация позволяет из одной точки управлять доступом пользователей ко всем базам 1С. Добавлять новых пользователей, отключать уволенных сотрудников, переназначать роли и профили (наборы ролей), импортировать настройки из конфигураций, инфобаз и Active Directory, выполнять автоматически в инфобазах любые дополнительные настройки после добавления \ обновления каждого пользователя.

20000 руб.

01.06.2017    23756    7    4    

Обработка для контроля онлайн ККМ (онлайн ККТ)

WEB Кассовые операции ККМ Кассовые операции v8 v8::УФ КА1 БП2.0 УТ10 УПП1 УНФ ERP2 БП3.0 УТ11 КА2 1С:CRM Россия БУ Платные (руб)

Обработка позволяет контролировать данные, которые онлайн ККМ уже отправила оператору фискальных данных и в ИФНС, если ваш ОФД - ofd.ru (Общество с ограниченной ответственностью «ПЕТЕР-СЕРВИС Спецтехнологии»). Удобно использовать для контроля торговых точек оснащенных онлайн ККМ, особенно, если их несколько. В любой момент времени можно получить текущее состояние продаж по кассе, вплоть до состава последнего чека (при условии устойчивой связи ККМ с ОФД).

1100 руб.

31.05.2017    22385    7    15    

Работа с онлайн-кассой Википринт Viki Print 57Ф из 7.7

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия БУ УУ Платные (руб)

Работа с кассами Википринт (производитель DreamKas) и Пирит из конфигураций под платформу 1С 7.7

3000 руб.

24.04.2017    28097    116    127    

1С:Предприятие 8 ПРОФ. Лицензии на сервер и рабочие места (USB, электронная поставка, мобильные) Промо

Администрирование данных 1С v8 1cv8.cf Платные (руб)

Лицензионная политика «1С» обеспечивает пользователям независимую масштабируемость – по функционалу прикладных решений и по клиентским рабочим местам. Чтобы расширить функциональные возможности используемой системы, требуется приобрести новые приложения. Если увеличивается число рабочих мест – необходимо приобрести дополнительные клиентские лицензии. Также возможен апгрейд лицензий. Обычно поставка ПО осуществляется с программной защитой. По более высокой цене можно приобрести ПО с аппаратным ключом защиты (USB).

1200 руб.

20.02.2016    25192    185    0    

Брандмауэр для сервера 1С Предприятие 8 - внешнее управление сеансами

Администрирование данных 1С v8 1cv8.cf Платные (руб)

Управление возможностью начала и возобновления сеансов пользователей по различным условиям, ограничение общего числа возможных сеансов для работы с информационной базой, резервирование возможности работы с информационной базой определенных польззователей, запрет запуска нескольких сеансов для пользователя, журнализация событий начала (возобновления) и завершения (гибернации) сеансов, ведение списка активных сеансов для информационных баз кластера серверов

1000 руб.

06.02.2017    18169    11    9    

54-ФЗ: Обработки для подключения онлайн-касс к 1С 8 (поддержка маркировки) + демо обработка + эмулятор

ККМ Фискальный регистратор Кассовые операции Розничная торговля Розничная торговля v8 1cv8.cf Россия Платные (руб)

Обработки осуществляют обслуживание фискальных регистраторов, поддерживаемых драйвером "АТОЛ: Драйвер ККМ v.10.6", "ШТРИХ-М: Драйвер ККМ v 4.14", "ВИКИ: Драйвер CSI v 1.4", "СПАРК: Драйвер v1.0", "ПИОНЕР" Драйвер v1.0 для конфигураций "Бухгалтерия 2.0", "Управление торговлей 10.3" (релиз 10.3.40.1), "Комплексная автоматизация 1.1" (релиз 1.1.82.1), "Управление производственным предприятием 1.3" (релиз 1.3.87.1), "Розница 1.0" (релиз 1.0.19.16), соответствующих требованиям закона ФЗ-54 о применении контрольно-кассовой техники.Поддержка НДС 20%.

3000 руб.

02.02.2017    189778    705    2015    

Загрузка классификатора банков с сайта "РосБизнесКонсалтинг"

Обработка справочников WEB Банковские операции Банковские операции v8 v8::БУ БП2.0 БУ Платные (руб)

Обработка является модификацией типовой обработки загрузки классификатора банков РФ, в которой добавлена возможность загрузки с сайта "РосБизнесКонсалтинг". При выборе данного варианта загрузки, она производится на клиенте и поэтому предоставляет возможность сделать это без доступа к интернету на сервере приложения в случае работы с клиент-серверной базой.

1000 руб.

07.10.2016    14307    5    2    

1С:Предприятие 8. Лицензии на сервер. Промо

Администрирование данных 1С v8 1cv8.cf Россия Платные (руб)

Лицензионная политика «1С» обеспечивает пользователям независимую масштабируемость – по функционалу прикладных решений и по клиентским рабочим местам. Серверные лицензии — необходимы для запуска кластера сервера «1С:Предприятие». Могут быть 32-разрядными или 64-разрядными. Причем лицензия на 64-разрядный сервер позволяет использовать и 32-разрядные рабочие процессы.

50400 руб.

20.02.2016    41633    84    0    

1С:Предприятие 8. Платформа и инструменты разработчика от Фирмы 1С

Администрирование данных 1С Россия Платные (руб)

1С:Предприятие 8.3. Технологическая поставка. Защищенный программный комплекс "1С:Предприятие 8.2z" (x86-32). 1С:Корпоративный инструментальный пакет 8. 1С:Сценарное тестирование 8. 1С:Предприятие 8. Система проектирования прикладных решений. 1С:Предприятие. Технология создания внешних компонент. 1С:Технология публикации решений 1cFresh. 1С:Технология разработки решений 1cFresh

750 руб.

11.02.2016    26758    3    0    

Две кассы на одном рабочем месте

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 УТ10 Розница Платные (руб)

Настройка для конфигураций Розница 1.0 и Управление торговлей 10.3, позволяющая использовать два кассовых аппарата на одном рабочем месте продавца.

2500 руб.

02.10.2015    33512    26    4    

Проверка баз 1С 7.7 перед переходом на 1С 8 БП 2.0

Администрирование данных 1С Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Закрытие периода Оборотно-сальдовая ведомость, Анализ счета v77::БУ 1С7:Бух Россия БУ Платные (руб)

Проверка готовности базы 1С 7.7 Бухгалтерия (и УСН) для возможности переноса данных стандартной обработкой в базу 1С "Бухгалтерия предприятия" 2.0. Позволяет проанализировать данные и исправить часто встречающиеся ошибки. Протестировано на 50 разных базах 1С 7.7.

2000 руб.

27.10.2011    16717    9    22    

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями в ФЗ от 01/07/19 Промо

Инструментарий разработчика Разработка внешних компонент WEB Кассовые операции ККМ Кассовые операции Фискальный регистратор Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия БУ УУ Платные (руб)

FR_ATOL_SHTRIH.EXE встраивается в SYSTRAY (в правом нижнем углу, там где часы) и следит за появлением обычного текстового файла, в котором перечислено, какие операции необходимо осуществить с ККТ - напечатать чек (нал/безнал), снять Z-отчет, осуществить выемку денег, сделать возврат и т.д. Такой механизм позволяет использовать комплект для WEB сайтов, для нетиповых или сильно измененных 1с7 или 1с8. Для любых программ, которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые к использованию обработки для 1с8: УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1С7.7:ТиС документ Реализация ТМЦ,Печать из ПКО, Бух4.5, Бух1.3 . Код на 1с открыт - используйте обработки комплекта, как шаблоны для своих программ. Подключать ККМ к 1С не надо! Более 300 внедрений на ККМ Штрих и Атол. Некоторые из покупателей реализовали работу с ККМ даже из Excel и Axapta.

1000 руб.

31.07.2017    56045    184    372    

Обмен между 1С:Розница и Frontol 6 по организациям Промо

ККМ Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ Платные (руб)

Обмен между 1С:Розница, редакция 2.3 и Frontol 6 при торговле от нескольких организаций. С апреля 2020 года обновлена под маркировку.

1800 руб.

22.03.2019    13748    21    70    

ККТ-ОНЛАЙН 54-ФЗ: Обработка для работы онлайн касс АТОЛ, ШТРИХ, VIKI PRINT и многих др. + Бесплатный тестовый период + ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА Промо

Фискальный регистратор ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 КА1 БП2.0 УТ10 Розница УПП1 БГУ БП1.6 БАУ 1С:CRM Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Можно подключить любую доступную онлайн кассу к практически любой конфигурации. Не требует обновления 1С. Бесплатное скачивание и тестирование функционала. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест через RDP, TCP\IP или веб-сервер. Может разделить чек на разные фискальные регистраторы. Можно использовать несколько систем налогообложения. Поддерживает создание собственного шаблонов чека. Работает на LINUX и Windows. Позволяет подключить сразу несколько эквайринговых терминалов. НДС 20%

1500 руб.

27.02.2017    386975    4389    7046    

Печать кассовых чеков на одну ККМ с нескольких рабочих мест для УТ 11.4, КА 2.4, Розница 2.2-2.3, УНФ 1.6, БП 3 ( 54-ФЗ, Управляемые формы, маркировка, егаис ) Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8::БУ v8::ОУ v8::УФ Розница УНФ БП3.0 УТ11 КА2 Платные (руб)

Расширение конфигурации для УТ 11.4, КА 2.4, Розница 2.2-2.3, УНФ 1.6, БП 3 (Управляемые формы) позволяет выполнять печать кассовых чеков на одну ККМ 54-ФЗ с нескольких рабочих мест. НИКАКИХ НАСТРОЕК В РАЗРАБОТКЕ - ПОДКЛЮЧИЛ И ПЕЧАТАЙ. Если у вас несколько отделов и одна ккм - печатайте на одну ккм! Если у вас две ккм и одна поломалась - печатайте на одну ккм, пока ремонтируете другую!

1000 руб.

27.08.2018    35812    267    146    

Мини-сервер 1С:Предприятие 8 на 5 пользователей и 1 программиста Промо

Администрирование данных 1С v8 Платные (руб)

Данный продукт представляет собой сервер "1С:Предприятия 8.3" уровня ПРОФ, который обеспечивает запуск не более пяти сеансов пользователей в режиме "1С:Предприятие" и еще одного сеанса в режиме "Конфигуратор" (всего шесть подключений, каждое из которых требует наличия клиентской лицензии). При этом в кластере серверов может быть не более одного рабочего сервера. Поддерживается работа 64-разрядного сервера "1С:Предприятия 8".

14400 руб.

27.01.2015    86235    28    146    

Сервер ККМ (54-ФЗ, быстрая печать чеков из терминального сеанса, печать с нескольких ПК) Промо

ККМ Разработка внешних компонент POS терминал Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Платные (руб)

"Сервер ККМ" позволяет приложениям работать с фискальными регистраторами из терминального сеанса Windows по локальной сети или интернет, организовать печать на одном ККМ с нескольких рабочих мест. Поддержка драйверов Атол, Штрих и VikiPrint. Поддержка 54-ФЗ. Подключается к 1С Торговля и склад 7.7, 1С:УТ 10/11, 1С:УНФ, 1С:Розница 1/2, 1С:БП 2/3, 1С КА 1/2., 1С:ERP, УПП

12000 руб.

02.09.2016    80302    178    144    

UTM Proxy для УТМ ЕГАИС (или как не пропустить дубль алкогольной марки и недостачу на кассе + Контроль МРЦ) Промо

Розничная торговля ККМ Розничная торговля Розничная и сетевая торговля (FMCG) Россия Акцизы Платные (руб)

Что такое УТМ прокси? УТМ прокси - это универсальное программное обеспечение для борьбы с дублями марок алкогольной продукции при розничной продажи. Данное программное обеспечение - это своего рода "прокладка" между кассовым ПО и УТМ ЕГАИС. UTM Proxy работает с любыми кассами, вот некоторые из них: miniPOS, рабочие места кассиров в конфигурациях 1С (в том числе и базовые версии), Фронтол и другие...

2000 руб.

16.11.2016    32445    190    60