Загрузка прайса. УТ 10.3

Публикация № 805845

Разработка - Обработки - Ценообразование, прайсы

Загрузка прайса

Самая простая загрузка прайса в УТ 10.3: копируете коды и цены из эксель на форму и загружаете. Интерфейс проще и понятнее, чем у типовой внешней обработки "Загрузка данных из табличного документа". Плюс данный способ применим для загрузки сложных прайсов (см. публикацию).

Приветствую всех!

Прислали мне прайс (см. картинку)

Я доработал свою же обработку по загрузке номенклатуры в 1с из эксель (для документов Поступление товаров и услуг) //cat.1module.ru/public/666516/

И получилось так, что не сложно было обучить менеджера загружать прайс в дальнейшем самостоятельно (см. картинку).

В дальнейшем на проекте автоматизации салона красок воспользовался данной обработкой для загрузки прайса пигментов разных цветов: каждый пигмент имеет название и номер цвета, цена зависит как от названия цвета, так и от номера цвета (см. картинку).

Для загрузки подобных прайсов (к слову сказать, в этой отрасли все прайсы двумерные) я доработал обработку следующим образом: обхожу табличный документ по горизонтали и вертикали - цикл в цикле - и для каждого сочетания НазваниеЦвета-НомерЦвета определяю и записываю цену (см. картинку)

Макет = ЭлементыФормы.ПолеТабличногоДокумента1;
Для К = 2 По Макет.ВысотаТаблицы Цикл
    Для Н = 2 По Макет.ШиринаТаблицы Цикл

        НазваниеЦвета   = СокрЛП(Макет.Область(1,Н,1,Н).Текст);
        НомерЦвета      = СокрЛП(Макет.Область(К,1,К,1).Текст);
        Цена            = СокрЛП(Макет.Область(К,Н,К,Н).Текст);

        Если Цена = "нет" Тогда
            Продолжить;
        КонецЕсли;

        НайденныйЦвет = Справочники.НазваниеЦвета.НайтиПоНаименованию(НазваниеЦвета,Истина);
        Если НЕ ЗначениеЗаполнено(НайденныйЦвет) Тогда

            Об = Справочники.НазваниеЦвета.СоздатьЭлемент();
            Об.Родитель = ГруппаЦветов;
            Об.Наименование = НазваниеЦвета;
            Об.Записать();
            НайденныйЦвет = Об.Ссылка;
        КонецЕсли;

        НайденныйНомерЦвета = Справочники.НомерЦвета.НайтиПоНаименованию(НомерЦвета,Истина);
        Если НЕ ЗначениеЗаполнено(НайденныйНомерЦвета) Тогда

            Об = Справочники.НомерЦвета.СоздатьЭлемент();
            Об.Родитель = ГруппаНомерЦвета;
            Об.Наименование = НомерЦвета;
            Об.Записать();
            НайденныйНомерЦвета = Об.Ссылка;
        КонецЕсли;

        Попытка
            Цена = Число(Цена);
        Исключение
            Продолжить;
            Сообщить("Возникла ошибка строка " + К + " колонка " + Н);
        КонецПопытки;

        НЗ = РегистрыСведений.ЦеныЦветов.СоздатьНаборЗаписей();
        НЗ.Отбор.НазваниеЦвета.Установить(НайденныйЦвет);
        НЗ.Отбор.НомерЦвета.Установить(НайденныйНомерЦвета);
        НЗ.Отбор.Период.Установить(Период);

        Запись = НЗ.Добавить();
        Запись.НазваниеЦвета = НайденныйЦвет;
        Запись.НомерЦвета = НайденныйНомерЦвета;
        Запись.Период = Период;
        Запись.Цена = Цена;
        НЗ.Записать();

    КонецЦикла;

КонецЦикла;


 

  К сожалению, на демо-УТ этот алгоритм не воспроизвести, поэтому выкладываю листинг алгоритма, который не включен в предлагаемую обработку. Просто, имея некоторый шаблон для работы с экселевскими данными, можно решать разнообразные задачи - в том числе загружать двумерные прайсы пигментов.

Представленная обработка тестировалась перед публикацией на платформе 8.3.11.3034 на демо-УТ 10.3.46.2.

 
 См. также

 

Скачать файлы

Наименование Файл Версия Размер
Загрузка прайса. УТ 10.3

.epf 7,39Kb
26.03.18
9
.epf 7,39Kb 9 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Список заказов поставщикам (новая форма) + два ноу-хау для разработчиков Промо

Рабочее место Дебиторская и кредиторская задолженность Оптовая торговля Дебиторская и кредиторская задолженность Оптовая торговля v8 v8::ОУ КА1 УТ10 УУ Платные (руб)

Представлена внешняя обработка - "Список заказов поставщикам (новая форма)". Удобство заключается в том, что в одном окне списка отображается структура всех связанных документов с указанием контрагента (заказ поставщику - поступление товаров - заказ покупателя - реализация товаров - оплата товара покупателем). В этом же окне отображается список товаров с заказанным количеством и ценами. Имеется возможность видеть статусы заказов по цветам (исполнен, выполняется, черновик). Форму легко встроить в типовую конфигурацию.

1100 руб.

31.08.2017    20303    18    18    

[Расширение] БП 3.0. Список счетов/ Список реализаций + Связанные документы

Рабочее место Оптовая торговля v8 v8::БУ БП3.0 БУ Платные (руб)

Список счетов / список реализаций + Структура подчиненности в одном окне. Расширение для программы БП 3.0.

1450 руб.

09.04.2020    2407    4    6    

Отображение цен и остатков в списке номенклатуры и подборах "как в УТ 10.3" в УТ 11, КА 2, ERP 2 (расширение, платформа 8.3.12+)

Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Посвящается Всем, кто привык к удобному отображению цен и остатков в конфигурации "Управление торговлей 10.3" в списке номенклатуры! Не требует модификации конфигурации, устанавливается как расширение! Выбранные виды цен сохраняются в рамках пользователя. Отображение идет в виде дерева по характеристикам. Работа проверена на конфигурациях УТ 11.4, КА 2, ERP2. (Обновление от 17.04.2020)

2 стартмани

31.03.2020    3011    24    hakerxp    10    

Авторегистрация закупочных цен для УНФ 1.6

Ценообразование, анализ цен v8 УНФ БУ УУ Абонемент ($m)

Автоматическая регистрация учетных цен (полной себестоимости), с учетом дополнительных расходов на приобретение.

2 стартмани

19.11.2019    4572    24    alexcne    4    

Как получить предыдущую цену номенклатуры Промо

Практика программирования Ценообразование, анализ цен Управленческие Ценообразование, анализ цен v8 1cv8.cf Абонемент ($m)

У новичков часто возникает вопрос как получить предыдущую цену или как получить предпоследнее значение из регистра сведений. В данной публикации я на примере опишу как это можно сделать

1 стартмани

08.05.2013    28047    22    Virikus    10    

Маркировка ячеек цветом. Отладка загрузки данных из эксель.

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

После 100-ой кривой загрузки родился способ, как отладить алгоритм.

05.07.2018    9193    Rustig    7    

Удобная загрузка номенклатуры, картинок, прайсов и накладных из Excel (xls) и dbf-файлов для 1с 8.1/8.2 (обычные формы) Промо

Учет ТМЦ Ценообразование, анализ цен Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel Учет ТМЦ Ценообразование, анализ цен v8 1cv8.cf Россия Абонемент ($m)

Удобная загрузка номенклатуры (с картинками), в справочник Номенклатура и любые документы с табличной частью Товары, включая УстановкуЦенНоменклатуры из Excel (xls) и dbf-файлов для 1с 8.1/8.2. Только в обычном (не управляемом) режиме запуска.

1 стартмани

20.10.2011    58819    178    sacred    347    

Загрузка номенклатуры из Эксель (новый взгляд)

Загрузка и выгрузка в Excel Обработка справочников Практика программирования v8 1cv8.cf Абонемент ($m)

Представлена обработка "Загрузка номенклатуры из Эксель" (новый взгляд). Подходит для любого формата и любой структуры Эксель, ОпенОфиса: потому что пользователь сам решает - что ему загружать, а что нет.

1 стартмани

29.08.2017    14959    18    Rustig    8    

Выгрузка товаров в YML (Яндекс маркет)

Розничная торговля Учет ТМЦ Ценообразование, анализ цен WEB Розничная торговля Учет ТМЦ Ценообразование, анализ цен v8 v8::ОУ УНФ УТ11 УУ Абонемент ($m)

Обработка выгрузки номенклатуры в формат Яндекс маркета YML из 1С: Управление торговлей и Управление небольшой фирмой. Обработка разрабатывалась для конкретной узкой задачи, не претендует на универсальность и выложена больше для примера работы с форматом, нежели как конечное решение. Но в целом может быть с небольшими доработками использована и для реальных задач. Работает для УНФ 1.6 и УТ 11. Управляемые формы.

2 стартмани

12.02.2017    19230    82    de0nis    6    

Доработка конфигурации Конвертация Данных (вер. 2.1.8.2)

Инструментарий разработчика v8 КД Абонемент ($m)

Добавил в конфигурацию Конвертация Данных (вер. 2.1.8.2): 1) появляющиеся подсказки по обработчикам 2) аналог "Найти в списке" 3) историю переходов по объектам ПКО

2 стартмани

24.12.2011    21317    11    Rustig    23    

Обновление цен номенклатуры из csv

Разработка внешних компонент Внешние источники данных Ценообразование, анализ цен Ценообразование, анализ цен v8 УТ10 Россия БУ Абонемент ($m)

Данная обработка выполняет обновление текущих цен номенклатуры из csv-файла.

1 стартмани

06.12.2011    4292    3    hyperbonus83    6    

Печать Ценников со Штрих-кодом для УТ

Ценники Учет ТМЦ Ценообразование, анализ цен Учет ТМЦ Ценообразование, анализ цен v8 v8::ОУ УТ10 Абонемент ($m)

Всегда устраивала типовая обработка "Печать Ценников", а тут вдруг понадобился штрих-код в ценнике, может конечно уже что и было сделано, признаюсь честно искал плохо :) Для себе накидал из типовой обработки. Выкладываю здесь, может, кому надо будет... можно допиливать дальше под свой вкус.

10 стартмани

13.09.2011    37867    52    WhiteShadow    42